UberStudent Forums

Help and Community for Users of Uberstudent
Return to UberStudent Home Page
It is currently Fri Apr 19, 2019 2:18 pm

All times are UTC

UberStudent Logo Shirt
Hey! You can wear this UberCool UberStudent Logo Shirt

Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sun Aug 10, 2014 9:05 pm 
UberStudent Forum Helper

Joined: Fri Jul 25, 2014 11:17 pm
Posts: 65
I want to buy one or more laptops to run Uberstudent on and am looking for some ideas what to get without braking the bank.
I'm thinking to buy used or refurbished, about 1-2 years old and without operating system, if that is available.
A high quality laptop that will be likely to last would be my choice.
I'd like an energy efficient processor with low heat production and low fan noise.
It should be able to support virtualisation and have a good battery life and full-size keyboard.
A touch-screen is not particularly important for me.
So in short, yesteryears dream-machine that will be happy to run Uberstudent without fuss but costs a lot less than new.
Any suggestions or experience reports with this would be much appreciated.

Thanks! :D


Get an UberCool UberStudent Shirt!

UberStudent Logo Shirt
UberStudent Logo Shirt by uberstudent
See other Uberstudent T-Shirts
PostPosted: Wed Aug 13, 2014 8:51 pm 
UberStudent Forum Helper

Joined: Fri Jul 25, 2014 11:17 pm
Posts: 65
I've ordered a used Lenovo Thinkpad T410, probably around 4 years old, for about $300.- .

l'll let you know if it works with Uberstudent once I've tried it out.

PostPosted: Thu Aug 14, 2014 5:12 am 
UberStudent Forum Helper

Joined: Sat Mar 16, 2013 3:34 am
Posts: 51
I just bought a Dell Latitude E6400 Core 2 Duo 2.53GHz 2GB RAM 32-Bit 80GB HD 256GB NVIDIA Win 7 Pro WiFi N off lease so 3 years old for $169 including tax plus free shipping. I have had good luck with Dell Financial Services on ebay which is where I have purchased my laptops. I have only used UberStudent on this machine in virtual box and live DVD. I pulled the 4GB RAM out of my other E6400 which I bought in March of 2013 which I paid $226 with Core 2 Duo 2.53GHz 4GB 32-Bit 150GB HD Vista Business and put the 2GB into that E6400. When the 4GB RAM was in the 2013 E6400 I ran US in VB but it did not perform near as well as in VB Win 7 Pro. I gave my daughter my Dell Latitude D630 Core 2 Duo 1.8GHz 2GB RAM 32-Bit 80GB HD which I bought in March 2012 for $165. I ran UberStudent installed to the HD on that machine. I installed 4GB RAM and a fresh install of UberStudent to HD before I gave it to her. She used it fall 2013 and spring 2014 semesters. I need to upgrade that to US 4.0 for Fall 2014. I hope you have much success with your LenovoThinkpad T410.

PostPosted: Mon Sep 15, 2014 1:21 pm 
UberStudent Forum Helper

Joined: Fri Jul 25, 2014 11:17 pm
Posts: 65
The Lenovo Thinkpad T410 arrived and Uberstudent works well on it. :D
It installed without fuss from a USB stick as dual-boot system in addition to Windows 7.

WiFi was detected automatically, so far no extra drivers were required.

I again had problems with the built-in updater in US: It just will not work until after I used sudo apt-get update in a terminal. Then it works temporarily.

I have not been able to get DVD playback or printer setup going so far.

Still need to try out running Virtual Box with Windows on it. I was able to turn on some virtualisation options in the BIOS, so I hope it will work.

I also bought a Lenovo Thinkpad T540p - this seems to be more trouble than the T410 for some reason. WiFi is not working, ethernet cable internet keeps dropping out. Will try to tackle that one again once the Thinkpad T410 is fully functional for my purposes.

PostPosted: Fri Sep 19, 2014 10:24 pm 
UberStudent Forum Helper

Joined: Fri Jul 25, 2014 11:17 pm
Posts: 65
Another update on the Thinkpad T410: It continues to work well with Uberstudent 4.0 .
Printer/scanner/fax is now working.
DVD playback only for the set region, still working on that.
Dual boot with Windows 7 works and Windows 8.1 runs in Virtualbox (and is a total pain). I need to try out of I can get Windows 7 to run in virtualbox to get an idea if it is preferable over dual booting. Rebooting is very fast with the solid state drive, maybe Virtualbox is not needed after all.

Below are some details of the computer.

Processor : 4x Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz
Memory : 7968MB (1640MB used)
Operating System : UberStudent 4.0 Socrates
User Name :
Date/Time : Sat 20 Sep 2014 07:55:59 AM EST
Resolution : 1280x800 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
Audio Adapter : HDA-Intel - HDA Intel MID
Audio Adapter : ThinkPad EC - ThinkPad Console Audio Control
-Input Devices-
Lid Switch
Sleep Button
Power Button
AT Translated Set 2 keyboard
Microsoft Microsoft® Nano Transceiver v2.0
Microsoft Microsoft® Nano Transceiver v2.0
Microsoft Microsoft® Nano Transceiver v2.0
Video Bus
SynPS/2 Synaptics TouchPad
TPPS/2 IBM TrackPoint
ThinkPad Extra Buttons
HDA Intel MID HDMI/DP,pcm : 8=
HDA Intel MID HDMI/DP,pcm : 7=
HDA Intel MID HDMI/DP,pcm : 3=
HDA Intel MID Headphone
HDA Intel MID Dock Headphone
HDA Intel MID Dock Mic
HDA Intel MID Mic
Integrated Camera
-Printers (CUPS)-
-SCSI Disks-
ATA Samsung SSD 840

PostPosted: Mon Sep 22, 2014 1:25 pm 
UberStudent Forum Helper

Joined: Fri Jul 25, 2014 11:17 pm
Posts: 65
The Lenovo Thinkpad T540p is trouble when combined with Uberstudent.

It probably is also trouble with other Linux distros and maybe even with Windows.

The wireless card in my refurbished T540p (which is different from the one which gained the T540p Ubuntu certification http://www.ubuntu.com/certification/des ... &level=Any , required that I changed some obscure setting in Windows 7 from "Performance" to "Wireless". Before that setting was changed, the wireless access would not work in Windows 7 for a random but lenghthy time each time the wireless ON/OFF keybord button was toggled.

In Uberstudent, the wireless card does not get detected, and several Ubuntu forum posts report similar problems for this wireless card in other distros.

With some other laptops I have had problems getting the wirless going in US, but a (commercial) distro called PartedMagic always found wireless access on those computers when booted from USB. But not so on the T540p: Not even PartedMagic finds the Wireless card.

The command "lspci | grep Network" results in this output:
04:00.0 Network controller: Realtek: Semiconductor Co., Ltd. RTL8192EE PCIe Wireless Network Adapter

The command: lspci -vv -s 04:00.0 results in this output:
04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192EE PCIe Wireless Network Adapter
Subsystem: Realtek Semiconductor Co., Ltd. Device 001b
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 10
Region 0: I/O ports at 4000 [size=256]
Region 2: Memory at f1400000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>

For those who can understand more of the Linux lingo, I suppose this link will explain how tricky this WiFi adapter is to get going: https://bugs.launchpad.net/ubuntu/+sour ... ug/1239578

To me, it seems like it might be a good idea to put a different WiFi adapter into the T540p, or to sell it again.

I have no idea if WiFi adapters can just be swapped to something more compatible with Linux, please let me know!

Another big negative for the T540p is that they replaced the usual Thinkpad trackpad / trackpoint combo with some very large toggle trackpad + trackpoint. Seems very hard to use to me, at least not intuitive or easy.

PostPosted: Wed Sep 24, 2014 11:04 pm 
UberStudent Forum Helper

Joined: Fri Jul 25, 2014 11:17 pm
Posts: 65
The Lenovo T540p continues to resist all attempts to get the built-in wireless network card going.

However, a "Wi-Pi" USB dongle (I had one lying around) works to get it on-line until the Ubuntu commuity has sorted out the driver issues for the rtl8192ee card.

I tried a few approaches from here: https://bugs.launchpad.net/ubuntu/+sour ... ug/1239578 but without success. This may entirely be due to my inexperience with kernel compilation and such stuff, but many others who seem to know more than me keep failing, too.

Among the unsuccessful attemps was this one:
sudo apt-add-repository ppa:mjeanson/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install rtl8192ee

How can I find out which kernel is in use in Uberstudent 4.0? Or is that altogether different from Ubuntu kernels anyway?

PostPosted: Mon Apr 06, 2015 11:49 am 
New UberStudent User

Joined: Mon Apr 06, 2015 11:36 am
Posts: 3
After a long research, I decided to go for the HP EliteBook Folio. The 14" screen fits my work style perfectly and with 8GB of ram and 256SSD I'm not worried about running low performance-wise anytime soon. By the way, if you're in Australia and would like to get a similar model, I'd suggest checking out Shopping Express' laptop deals as you can find both standard laptops and ultrabooks at 30% discounts, which is like, super awesome.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

Click Here to Get Inexpensive UberStudent Discs

Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group